čtvrtek 20. října 2005

Eclipse 3.1 a podpora generických typů

Některé články se objeví přesně v ten moment, kdy mi to přijde vhod. Asi před čtrnácti dny jsme se čistě ze strategických důvodů rozhodli přejít na Javu 5.0. Základní premisou pro vývoj v pětkové řadě je podpora nových jazykových konstrukcí jako jsou například generické typy. V případě IDE Eclipse, které ve firmě používáme, je plná podpora Javy 5.0 implementována ve verzi 3.1.

Než se vrhnete na používání Javy 5.0 v Eclipse, budete muset nastavit minimálně kompilátor pro 5.0 a tím pádem, aktivujete podporu 5.0 v standardních nástrojích IDE, jako Quick Assist, Quick Fix, refactoring a tak dále. Pokud už v tom budete a přecházíte na stávajícím projektu, doporučuji v nastavení kompilátoru, záložka Error/Warnings, změnit v J2SE 5.0 Unchecked generic type operation na hodnotu ignore.

Pokud máte úspěšně zkompilováno a chcete vyzkoušet nějaký ten nový konstrukt, není lepší volba než generický typ. No, a pokud jste zvědaví, jak vám v tom Eclipse pomůže, můžete zkusit prolétnout článek Neala Forda Java generics support in Eclipse V3.1